2003 Ford Expedition XLT 4x4... hesitates on accelaration - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-26-2008, 15:50   #1 (permalink)
Registered User
 
Join Date: Jul 2008
Posts: 2
2003 Ford Expedition XLT 4x4... hesitates on accelaration

Hello every one, this is my first post. I recently purchased a 2003 Ford Expedition XLT 4x4 with 74K miles. Truck runs real good but has slight hesitation on accelaration. The hesitation on accelearation is while accelerating from a stop or while idleing at a speed lets say 30 - 40mph and stepping on the accelerator ....

Any advice? i put 93 octane fuel.

Thanks :)
miamidiesel is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-26-2008, 15:51   #2 (permalink)
Registered User
 
Join Date: Jul 2008
Posts: 2
Re: 2003 Ford Expedition XLT 4x4... hesitates on accelaration

Also, forgot to mention there is no check engine light on or anything.
miamidiesel is offline   Reply With Quote
Old 07-27-2008, 12:36   #3 (permalink)
Ex-Ford master tech
 
Join Date: Aug 2007
Location: Colorado
Posts: 59
Re: 2003 Ford Expedition XLT 4x4... hesitates on accelaration

Even without a CEL being on, there can be "pending" codes that might lead to the problem area. Check for vacuum leaks, and check the rubber ducting between air cleaner housing and engine for leaks.

If you find any codes, post them here before buying any parts.
btexpress is offline   Reply With Quote
Old 07-31-2008, 22:01   #4 (permalink)
Registered User
 
Join Date: Jul 2008
Posts: 1
Re: 2003 Ford Expedition XLT 4x4... hesitates on accelaration

Funny that this happened to you too. I have a 2004 Navigator it sounds like the same thing that happened to me. I took it to my mechanic and it never happpened for him. I needed a new plugs so I did that anyway. It still happened. He suggested I take it to the dealer because there machinery was more sophisticated and might show the problem. Anyways they did a full diagnostics and nothing showed. They installed a flight recorder and just my luck nothing has happened in two weeks. However there was an update that had to be put on the computer so they did that however he didnt seem to think that that would be the problem, but you never know. My truck actually stalled on me a few times. It usually happened from a stop when I wanted to accelerate, but it also was happening as I was driving on the freeway at even with the cruise on. It would just kind of jump or want to stop almost it was hard to explain. Does this sound like the same thing?
stevebazz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 07:09.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.