2003 Nav Sytem Fried? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-23-08, 12:12 PM Thread Starter
Registered User
 
Join Date: Mar 2008
Posts: 2
confused 2003 Nav Sytem Fried?

Hello,

My 2003 Expedition NAv system doesn't seem to pick up the sattelite signal. Is there a reset for the system? Are there any sources for information on this system?

Is there some kind of remote satellite antenna for this thing?

Any help would be appreciated.

Thanks,

Paul
FordExp03 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-27-08, 01:11 PM
Registered User
 
Join Date: Mar 2008
Location: California
Age: 54
Posts: 8
Re: 2003 Nav Sytem Fried?

As far as I am aware the Navigation system operates off a Navigation CD, not sure where it gets the location signal from. It may durive it from the compass and satellite antenna.

At first I thought your XM was dropping out, which can occur in the Northern regions of the US with mountains next to you.
BigWheelsRolli is offline  
post #3 of 3 (permalink) Old 03-30-08, 07:10 PM Thread Starter
Registered User
 
Join Date: Mar 2008
Posts: 2
Re: 2003 Nav Sytem Fried?

Quote:
Originally Posted by BigWheelsRolli View Post
As far as I am aware the Navigation system operates off a Navigation CD, not sure where it gets the location signal from. It may durive it from the compass and satellite antenna.

At first I thought your XM was dropping out, which can occur in the Northern regions of the US with mountains next to you.

The Nav CD appears to work. I can see the map and my home location. I just don't seem to be getting a signal from the sattelite. My direction signal is red..which means weak or no sattelite signal.
FordExp03 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome