2003 Nav won't start after Battery Replacement - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-19-2013, 09:38   #1 (permalink)
Registered User
 
Join Date: Jul 2010
Posts: 5
2003 Nav won't start after Battery Replacement

I've been searching the threads for a while and haven't been able to find anything on this topic so here goes. I replaced my battery and now my nav won't start. It turns over without hesitation but it won't start. Am I missing something here? What would cause this?

thanks.
humnbass is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-19-2013, 14:14   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,704
Re: 2003 Nav won't start after Battery Replacement

You may have knocked something loose. Try disconnecting and reconnecting the battery to see what it does.
__________________
Bert
Bert is offline   Reply With Quote
Old 02-19-2013, 14:34   #3 (permalink)
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 3,571
Re: 2003 Nav won't start after Battery Replacement

The other possibility is that your Nav's security is not recognizing your key.
__________________
'Scuse me, while I scrape this Honda outta my treads.
CatSkinner is offline   Reply With Quote
Old 02-20-2013, 07:38   #4 (permalink)
Registered User
 
Join Date: Jul 2010
Posts: 5
Re: 2003 Nav won't start after Battery Replacement

It's turning over but it will not crank up. It was running fine prior to me changing the battery. I have no idea what it could be. None whatsoever.
humnbass is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 14:23.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.