2003 Nav won't start after Battery Replacement - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-19-13, 10:38 AM Thread Starter
Registered User
 
Join Date: Jul 2010
Posts: 5
2003 Nav won't start after Battery Replacement

I've been searching the threads for a while and haven't been able to find anything on this topic so here goes. I replaced my battery and now my nav won't start. It turns over without hesitation but it won't start. Am I missing something here? What would cause this?

thanks.
humnbass is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-19-13, 03:14 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,283
Re: 2003 Nav won't start after Battery Replacement

You may have knocked something loose. Try disconnecting and reconnecting the battery to see what it does.

Bert
Bert is offline  
post #3 of 4 (permalink) Old 02-19-13, 03:34 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 5,455
Re: 2003 Nav won't start after Battery Replacement

The other possibility is that your Nav's security is not recognizing your key.

Chewing on asphalt and drinking dinosaur wine
CatSkinner is offline  
post #4 of 4 (permalink) Old 02-20-13, 08:38 AM Thread Starter
Registered User
 
Join Date: Jul 2010
Posts: 5
Re: 2003 Nav won't start after Battery Replacement

It's turning over but it will not crank up. It was running fine prior to me changing the battery. I have no idea what it could be. None whatsoever.
humnbass is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome