2003 Navigator - Electrical? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-18-2010, 05:55   #1 (permalink)
Registered User
 
Join Date: Apr 2009
Posts: 6
2003 Navigator - Electrical?

Where to start. I bought my Navigator a year ago and I am in my second winter with it. When it is extremely cold the Navigation system/radio does not come on right away. It is like clock work, it warms up, and bingo on it comes. I thought this was a built in safety feature because of the navigation screen but this winter it is much worse and I have also noticed that when the navigation system is not on, also the driver side window does not work and also the rear vent windows dont work. Pretty sure we don't have a built in safety feature after all. Can anyone help with this.

Also in the last week my wiper fluid pumps have quit working for both the front and the rear. The wipers work but the fluid does not. Checked the fuses and they appear to be fine. Any other roads to go down?

Thanks
Mike
AllezRocket is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-18-2010, 11:22   #2 (permalink)
Registered User
 
Join Date: Oct 2009
Location: Mililani, Hawai'i
Posts: 12
Re: 2003 Navigator - Electrical?

Sounds like cold solder joints on the circuit boards - a pretty common problem with the 0103 sized components on them - the only solution is to replace the radio... unless you want to dismantle it and reflow the solder on about 2000 joints! The standard blue colored wiper fluid will freeze - unless you switched it out for the stuff that's rated -25 (or whatever it is) the pump and lines are probably frozen.
Eddie Bauer is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 07:17.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.