2003 navigator issues. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-25-2013, 07:24   #1 (permalink)
Registered User
 
Join Date: May 2013
Posts: 2
2003 navigator issues.

I have a strange one here. My wifes 2003 lincoln navigator died out on her while stopped at a red light. she tried multiple times to restart it with no luck. the truck was towed before i got to it. when i arrived at the tow yard to pick it up, for the heck of it i tried to start it and it fired right up. she drove it for a week with no issues. i told her if it happened again to call me right away. a week later it died on her again in a parking lot. I drove over and tried to start it with no luck, i turned the key off and waited 30 minutes and tried again with no luck. the truck was towed home and as soon as it was off the truck it started right away. i have now started driving it so my wife/kid dont get stranded. i changed the fuel filter and ran a scan with no codes showing. after the scan the advance track light came on and the code will not clear for it. i have been driving the truck for 2 weeks with the only issue being a 2 second sputter on the expressway during a 35 mile drive, this was before i changed the fuel filter. i would appreciate any feedback. also it has 117k miles and runs perfect
WODY7227 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-25-2013, 07:28   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,727
Re: 2003 navigator issues.

When it doesn't start, check if the fuel pump comes on for a few seconds every time the key is turned to run.
__________________
Bert
Bert is offline   Reply With Quote
Old 05-25-2013, 07:35   #3 (permalink)
Registered User
 
Join Date: May 2013
Posts: 2
Re: 2003 navigator issues.

thats my plan if it happens again. you cant hear the fuel pump unless you put your head inder the truck so i will have to have someone else turn the key. just curious if anyone else has had issue. my first thought was fuel pump but it has ran fine for a week after each time
WODY7227 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 15:26.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.