2005 Expedition Hard Start and Rough Idle - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-10-2009, 13:36   #1 (permalink)
Registered User
 
Join Date: Jul 2008
Posts: 4
2005 Expedition Hard Start and Rough Idle

Can anyone help me out a little on this please. it has the 5.4 in it. has all new motorcraft plugs. a while ago i had a check engine light and it was for a #5 cyl. misfire. replaced all plugs and the #5 coil pack and ran great. several months later it is idling rought again and if it sits for a while and you go to start it, it cranks alot before she starts. but after that it starts fine. vehicle runs good just driving it, just idles a little rough when you ate stopped. No check engine lights at this time. Has there been issues with the fuel pumps or injectors on these motors? any help is greatly appreciated. also if it is a injector or fuel pump problem for the hard start , will my powertrain cover this. vehicle has 66,000 miles.

Thanks
2qk4u is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-11-2009, 19:26   #2 (permalink)
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,475
Re: 2005 Expedition Hard Start and Rough Idle

Chances are your powertrain warranty is up. I'd also assume that if your problem is sensor related (IAC/TPS/EGR/MAF) then the powertrain warranty wouldn't cover those components. EGR and MAF should be covered under emissions warranty, if I'm not mistaken. I'd replace the idle air control sensor around the throttle body for around $40-50 depending on where you can find it. It only takes 10min or so to install with basic hand tools. It may not hurt to get the vehicle scanned for any saved codes even if the engine light isn't on
__________________
'00 Durango R/T 360ci 290hp (modded); 138,500m
'06 Pontiac G6 GT 3.5L 220hp; 44,000m
'12 Chrysler 200 Limited 3.6L 283hp; 13,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 01:44.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.