2006 Expedition 5.4 Sputtering - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-20-2012, 19:05   #1 (permalink)
Registered User
 
Join Date: Feb 2012
Posts: 2
2006 Expedition 5.4 Sputtering

I just bought a 2006 expedition 5.4 with 90K miles and after the engine is at full running temperature, it sputters at 1500-1600 rpms but only when the engine is under slight or heavy load. What I mean is, only going slightly up hill or more. As soon as I back off the throttle or throttle up, it stops. It is not showing any check engine lights nor reading any codes on my cheap code machine. After reading several threads, I am fairly confident it's a COP but how can I check to see which one? I have a volt/ohm meter but haven't ever used it nor know how. Any quick tips on using the meter to check the COPs?
ddgoob is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-20-2012, 19:12   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,715
Re: 2006 Expedition 5.4 Sputtering

This is what the ohm readings should be but it usually doesn't show. A shop with a scope can tell. Stop by Autozone to see if they can pull any codes.

Ignition Coil Resistance
Primary 0.30-0.80 Secondary 5.50 K
__________________
Bert
Bert is offline   Reply With Quote
Old 02-20-2012, 19:22   #3 (permalink)
Registered User
 
Join Date: Feb 2012
Posts: 2
Re: 2006 Expedition 5.4 Sputtering

I'll swing by Autozone like you suggest. Thank you very much!
ddgoob is offline   Reply With Quote
Old 02-20-2012, 19:42   #4 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,715
Re: 2006 Expedition 5.4 Sputtering

Also, get some MAF cleaner and clean the MAF. That often helps the gas mileage.
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 10:59.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.