2011 Blizzard King 05 Expo - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-03-11, 04:52 AM Thread Starter
Registered User
 
Join Date: Jan 2011
Posts: 4
2011 Blizzard King 05 Expo

Just thought I would boast about how well my expo preformed on 15 + inches of snow. I got temporarilly stuck in a 4 foot drift got out with the truck still in Reverse and all four wheels where turning slowly around. I got back in and put it in 4 low and pounded my tranny a few times and she worked out of it. Awsome! Then I pulled out a car then the best was when I pulled out a mini van, out of another 4-5 ft deep drift with two Dodge trucks sitting watching me (friends of the driverof Mini) Put it in 4 low and hit it. She bounced around a few times and pop the van came right out. I jumped out and unhooked the chain and told those Dodge boys you should have bought a Ford and drove off. Loved it could not have been happier with the preformance of the truck in DEEP DRIFTING SNOW.

zek4964 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-03-11, 08:59 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,298
Re: 2011 Blizzard King 05 Expo

Sounds like a great test, thanks for sharing.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome