97 Expedition -- air suspension problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-03-2008, 14:35   #1 (permalink)
Registered User
 
Join Date: Jun 2008
Posts: 1
confused 97 Expedition -- air suspension problem

I'm hoping someone out here can tell me what the heck happened with my Expedition last night!!

Brief history: Had suspension gone over in April -- needed new compressor, which was installed, and everything hunky-dory.

Last night kids & I got in car and right as I was going to start it, the was a very big BANG! and the back end dropped all the way down. Some people in the parking lot heard it and thought either a line was blown or air bag blew. So I left it there and returned later (about 2 hrs) to pick up gear from inside and was going to have it towed to Ford repair shop. When I got there, I realized it was back up where it is supposed to be and everything looked fine, so I drove it home (with no problems) and now I'm looking for an answer to what happened.

When I contacted Ford and explained what happened, they had never heard of such a thing before. I asked if they had come up with some kind of self-healing air bags or lines -- wouldn't that be nice?

If any of you out there have experienced this or know anything that may be helpful, I would appreciate it if you would share with me!

Thanks!
tlbarry is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 00:00.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.