98 expedition radio - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-06-06, 07:46 AM Thread Starter
Registered User
Join Date: Mar 2006
Location: Texas
Posts: 3
98 expedition radio

98 expedition, eddie bauier edition. Has the mach audio system. Subwoofer in the back panel not working. amp or speaker u think. we bought it used, and no workie. Person we bought it from I know didn't crank it up to blow this stuff. wiring problem maybe? checked all fuses and non blown. Also, the back wiper just stopped outa the blue. did work the first day we got it. I can careless about this but the wife is asking me to fix. hah. btw, checked fuse there too, not blown. thinking maybe the relay in the back, or possible motor.


00 Dodge Ram 1500 4x4
98 Ford Expedition
djr4x4 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 03-16-06, 08:36 PM
Registered User
Join Date: Jan 2006
Location: Tioga, LA, USA
Posts: 148
Re: 98 expedition radio

Where in TX do you live? Is it possible that this truck was in NOLA for the Hurricaines? They say that 70-80% of the vehicles declared there as "totalled" will end up back on the streets to unsuspecting buyers. Sounds like a lot of little electrical shorts to me...kinda' like what happens when vehicles get flooded. Check it out before there's no recourse. If that's not the case, get a meter and start tracking!...that's about all you can do.
redneckf150 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome