98 expedition, surging at idle, check engine light on. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-10-11, 11:41 AM Thread Starter
Registered User
 
Join Date: Aug 2011
Posts: 1
Wink 98 expedition, surging at idle, check engine light on.

okay so heres a complete description. The car started surging at idle, eventually the check engine light poped on after a few days, i checked oil, it appears to be way low, even though ive had an oilchange about 2 months ago or less. Checked the coolant reservoir, and the water level was normal, however it was pretty dirty, and after draining there was alot of sludge stuff in the bottom. Not sure what it is, thought it was maybe oil, however shouldnt oil float to the top? upon looking at the oil dipstick i did not notice any odd coloration or residue in the small amount of oil there. Guess ill have to drain it all out to really check.
No smoke in exhaust, so im ruling out any water in the oil though.
Will check codes tommorow, but thought id see what you people had as far as opinions now.

I poped a quart of oil in, to see if the check engine light would vanish.. it did not. But maybe it needs to be cleared first? After flushing and refilling radiator, and adding a quart of oil, i ran the car for a little while in the drive way, and it appears to still be surging, i did not drive anywhere but just let the car idle in park.

That seems like alot of detail, hope someone can get some idea from it.

Thanks

Also after draining i checked the bucket for oil, and although there was sludge i saw no rainbowishness, or any seperation of oil at top, only black sludge in bottom. However after refilling reservoir, i did notice tiny microdroplets of oily substance, ontop of new clean water, not sure if thats normal or not. Just praying its not a blown head gasket lol

mbcezium is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-10-11, 05:59 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,300
Re: 98 expedition, surging at idle, check engine light on.

The light won't come on for low oil. There's a running problem that needs fixing. Get the codes read before you do any more with it. Disregard the oil for the running problem. It could be that whoever changed the oil didn't put enough in. Post the codes here and we'll try to see what's up.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome