98 Navi starts then dies - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-30-2010, 15:02   #1 (permalink)
Registered User
 
Join Date: Sep 2010
Posts: 1
confused 98 Navi starts then dies

I think I tried to read every post and did not find an answer. I have a 98 Navi and replaced the alternator and the battery and NOW when it starts (right when you turn the key) it runs for 20 seconds then dies. And also, the battery light does not go off! Any thoughts on this would be greatly appreciated.

Thanks,
Jesse
Jesse_white is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-30-2010, 23:20   #2 (permalink)
IT CAN ALWAYS BE BETTER
 
Join Date: Sep 2010
Location: AMSTERDAM
Posts: 54
Re: 98 Navi starts then dies

I think there must be a wire that is not connected propperly
check at the battery if it is charged by the alternator when running which means you must do that within 20 sec that it runs.

I guess not all the wires are connected or not making good contact
NAVMAN is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 06:58.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.