98 navigator, Blinkers wont work - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-06-2008, 17:46   #1 (permalink)
Registered User
 
Join Date: Nov 2007
Posts: 2
98 navigator, Blinkers wont work

I got my truck back from the inspection station today, I go to drive it home and the blinkers dont work at all. When I engage the signals I get nothing no fast blink, nothing even lighting up on the dash. I had the passenger side rear out prevous to bringing it there but it always blinked fast and the front would work. Now nothing, I got no fronts or rears. I checked all the fuses and there all good. Has this happened to anyone before? Any suggestions would be great. Thanks in advance.
georgekobe8 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-06-2008, 19:19   #2 (permalink)
Ex-Ford master tech
 
Join Date: Aug 2007
Location: Colorado
Posts: 59
Re: 98 navigator, Blinkers wont work

The turn signal switches are weak on Fords. Try turning on the emergency flasher and wiggling that button, move it around, if the flashers stop and start, the switch is bad.
btexpress is offline   Reply With Quote
Old 03-06-2008, 20:33   #3 (permalink)
Registered User
 
Join Date: Nov 2007
Posts: 2
Re: 98 navigator, Blinkers wont work

I should have written it in the first post but the hazards never worked for some reason.
georgekobe8 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 04:50.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.