99 Expedition with many problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-22-07, 08:06 AM Thread Starter
Registered User
Join Date: Jul 2007
Posts: 3
confused 99 Expedition with many problems

It started out with the expedition getting stuck into park. One suggestion was to change the shift interlock solenoid. I purchased one and started taking my dash apart to locate it and I took out the ignition switch to test it because someone else had recommended to. It checked out fine, but the day before the SUV got stuck in park the wiper light and 4X4 light on the dash would come on for a split second and then go out and at that very time the radio would go off. If I put the SUV in park the radio would come on again. If that wasn't weird enough, now the windows don't work, the wipers in front and back don't work along with the washer pump, and my foglights and running boards don't work either. One of the manuals that I have has an electronic diagram and I see the GEM module connected to almost everything that is going wrong. In some of the forums that I have been reading it seems that there may be a faulty windshield seal as the culprit causing the GEM and fuse box panel going bad. Someone also suggested checking the TRS (transmission range selector), I couldn't find where it was located. I just wanted to post this to see if anyone could confirm or argue what could really be going wrong here. The GEM is about $310 and the body control module is about the same or more just for parts. That's a lot of money to just replace and pray that it works. ANY HELP IS APPRECIATED!! can reply to jandmcrites@adelphia.net also.

Thanks in advance.
jcrites is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome