99 Expo Tranny question - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-02-2008, 18:00   #1 (permalink)
Registered User
 
Join Date: Nov 2007
Posts: 4
99 Expo Tranny question

Hey guys and gals I've got a great question for ya. I have a 99 expo eddie bauer with 183,000 miles. This trucks runs great, and I am all about the oil changes. I sdo have a question . I haven't changed the tranny fluid in about 2 years. It is not dirty but I have heard on old trannys not to keep changing fluids because of the seals setting etc. Should I keep it changed or not??????
Expo99Guy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-03-2008, 11:24   #2 (permalink)
Registered User
 
RickMN's Avatar
 
Join Date: Jul 2007
Posts: 231
Re: 99 Expo Tranny question

If you have been changing the fluid according to the maintenance schedule, you can keep right on changing it. It's when you've never changed the fluid, or haven't done it in 100K miles that you run into a problem. Here's an article on the subject: Trans Fluid Change
__________________
I'm a retired ASE Master/L-1 Technician. I still keep current with the latest automotive technology. Visit my blog for cool articles and TSB's: http://www.ricksfreeautorepairadvice.com/
RickMN is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 08:58.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.