Anybody have this problem? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-18-07, 06:46 PM Thread Starter
Registered User
 
Join Date: Jun 2007
Location: colleyville,tx
Posts: 11
Anybody have this problem?

My wifes 2004 expedition has a seat propblem on the second row, door seat. It clicks loudly when you sit down or move when you are on it. What could it be? Anyone had this prob?

chevy=garbage is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-12-07, 04:26 PM
Registered User
 
RickMN's Avatar
 
Join Date: Jul 2007
Posts: 231
Re: Anybody have this problem?

The foam is mounted to a plastic body form inside the seat. The plastic form is mounted to a steel outer frame. If you had any heavy weight on the seat, you could have cracked the body form panel. Then it would creak every time you moved in it.

I'm a retired ASE Master/L-1 Technician. I still keep current with the latest automotive technology. Visit my blog for cool articles and TSB's: http://www.ricksfreeautorepairadvice.com/
RickMN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome