Battery light stays on after key removed - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-12-07, 05:06 PM Thread Starter
Registered User
 
Join Date: Jul 2007
Posts: 3
Question Battery light stays on after key removed

I have a 2000 ford expedition and found out last night that after the key is removed the red battery indicator on the instrument panel stays lit, the defroster still runs and the digital readout for mileage is lit all the time and stays this way until the battery dies. Something is staying on or telling these things to stay on for some reason. The battery is one year old and checks fine, the alternator checks out fine at the local auto parts store, I checked the ignition switch also according to the haynes manual and it checks out fine. So I need help in trying to figure out what is going wrong. I have 104,000 miles on this vehicle, and a friend told me that it might be a tube and plunger on the steering column that needs to be replaced and is ussually the problem with these symptoms. Please help if anybody knows or has seen this.

kjblik is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome