Code 52 Airbag light 1998 Ford Expedition. How do you fix it???? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-02-2007, 21:12   #1 (permalink)
Registered User
 
Join Date: Jul 2007
Posts: 2
Code 52 Airbag light 1998 Ford Expedition. How do you fix it????

I recently had my car detailed and when I brought it home the electrical started going haywire. I tried to trouble shoot the problem but was unable to locate anything. The next morning my car battery was dead. I had to jump start my car. Now the airbag light is blinking 5 times, then pauses and then blinks two times. I have read a lot about this code 52 problem and have tried to fix it but no luck. Can anyone help me with this. I dont want to have to take it in to the dealership.
Aframe is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-12-2007, 15:23   #2 (permalink)
Registered User
 
RickMN's Avatar
 
Join Date: Jul 2007
Posts: 231
Re: Code 52 Airbag light 1998 Ford Expedition. How do you fix it????

I wonder if the cleaning crew got a little overzealous with the cleaning supplies and got some in the connectors to the air bag. If you de-power the air bag, check the connectors to make sure they're dry.
__________________
I'm a retired ASE Master/L-1 Technician. I still keep current with the latest automotive technology. Visit my blog for cool articles and TSB's: http://www.ricksfreeautorepairadvice.com/
RickMN is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 17:56.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.