Coil Damaged due to Cleaning - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-23-06, 07:57 AM Thread Starter
Registered User
 
Join Date: Oct 2006
Posts: 1
Coil Damaged due to Cleaning

I am looking to purchase a 2002 Expedition XLT with 88000 miles on it.I loved everything about it except when I took it for a test drive it seemed it skips every so often almost like a clogged gas line. (It didn't feel like a transmission slip). Well I told the salesman about it, and he guarantees me that it is just a coil problem. That he sees it all the time with Expeditions. When the dealers steam(power) clean the engine, they damage a coil. Does this make sense. Mechanical folks I spoke with at church about it, had no clue what he was referring to. Does this indeed happen and if a coil is bad, is this what would happen while driving on a highway. Thanks for any help. I'm supposed to close the deal today.

kgajfan1 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-23-06, 11:03 AM
Hi-Tech Redneck
 
Johnny Mullet's Avatar
 
Join Date: Jun 2006
Location: Ashtabula, Ohio
Age: 45
Posts: 1,486
Re: Coil Damaged due to Cleaning

I work at a dealer and see this here and there when the prep guys wash the engine. Make sure it is fixed before buying it. Take it on a good, long test drive.
Johnny Mullet is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome