Coolant leak HELP - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-19-09, 04:08 AM Thread Starter
Registered User
Join Date: Nov 2009
Posts: 1
Exclamation Coolant leak HELP

Whats going on fellas, Im in need of help, my 99 Navigator(4x4 5.4)has been having a significant coolant leak. Right away I thought it was the water pump and having 100k miles suggested I should replace it as well with the radiator. Well to my surprise as I took off the old pump it was completly dry in the front but had a pool of coolant directly behind it on the block itself. Ok so I figured it was the seal that went bad. I installed the new one and at first no leaks until about 3hrs later and only drove it around my street for a bit and resulted with a pool of coolant under the truck, doesnt drip in the front but in the middle by the transmission area-guess it funnels and drips there. If someone has a clue please lmk also if someone could provide with the schematics of the cooloant system for my truck that would be greatn Thanks in advance!!!
NaviRider is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome