EB expedition mileage problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-03-07, 11:30 AM Thread Starter
Registered User
 
Join Date: Oct 2007
Posts: 1
EB expedition mileage problem

i have a 2004 EB exp. and when i first bought it - i would fill the gas tank and it would say i would have around 420 miles to empty.

but now when i fill it (which cost alot more than when i first bought the car) it says i have 320 miles to empty.

so not only am i paying for more gas - i am not getting as many miles.

has anyone else had this problem.

oh - BTW - i am also have rear AC problems - and read a thread on how to fix it with part number and everything - going to try it very soon. i am glad this forum exist.

thank you

bochica is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-07-07, 02:25 PM
Registered User
 
Join Date: Apr 2007
Posts: 7
Re: EB expedition mileage problem

I think the miles to empty is calculated by the GPA of the last tank of gas. So if you were driving mostly highway, it would show more miles to empty than if you drive in the city.
KeithKman is offline  
post #3 of 3 (permalink) Old 11-12-07, 05:27 PM
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,481
Re: EB expedition mileage problem

Miles to empty is there to remind you of the distance you have left. If you drove all highway miles you'll get a longer range than if you drove mostly around town. Best way to calculate is MPG not miles to empty.

'11 Ram Quad Cab 4x4 SXT 5.7L HEMI (stock); 48,500m
'06 Pontiac G6 GT 3.5L 220hp; 64,000m
'12 Chrysler 200 Limited 3.6L 283hp; 28,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome