Engine Trouble? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-29-14, 05:30 PM
CarTrouble1
Guest
 
Posts: n/a
Engine Trouble?

I've been having trouble with 06 Expedition for a few months. At first I had sputtering and occasional banging. I had diagnostics run and got "misfire on 3" and "trottle acctuator control system". The throttle body has since been cleaned and the third spak plug and coil were replaced. Since I'm having even more trouble. I'm finding it difficult driving up slight inclines, even on the highway. I begin losing speed and end up at a complete stop. Any ideas?
 
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-29-14, 06:45 PM
Moderators
 
r-clar's Avatar
 
Join Date: Feb 2013
Location: Demotte Indiana
Posts: 1,884
Re: Engine Trouble?

Is it misfiring again?


Sent from AutoGuide.com App
r-clar is offline  
post #3 of 4 (permalink) Old 01-30-14, 06:43 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 5,450
Re: Engine Trouble?

Any codes?

Chewing on asphalt and drinking dinosaur wine
CatSkinner is offline  
post #4 of 4 (permalink) Old 02-03-14, 06:48 PM
Registered User
 
Join Date: Jun 2007
Posts: 372
Re: Engine Trouble?

Quote:
Originally Posted by CarTrouble1 View Post
I've been having trouble with 06 Expedition for a few months. At first I had sputtering and occasional banging. I had diagnostics run and got "misfire on 3" and "trottle acctuator control system". The throttle body has since been cleaned and the third spak plug and coil were replaced. Since I'm having even more trouble. I'm finding it difficult driving up slight inclines, even on the highway. I begin losing speed and end up at a complete stop. Any ideas?
Really sounds like your Electronic throttle body is failing, anytime we have one in with a TAC code they usually get a new ETB since it is failing internally.

Check out all my Ford Tech Repair Videos @
http://www.youtube.com/user/FordTechMakuloco
Please Subscribe. Always something new and interesting!
makuloco2000 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome