Expedition battery will not hold a chrage - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-03-08, 02:05 PM Thread Starter
Registered User
 
Join Date: Jun 2008
Posts: 2
Expedition battery will not hold a chrage

Expedition battery will not hold a chrage for long that is. I was driving when suddenly it died out. I replaced the battery and the alternator, but still the vehicle can be driven for 1-3 hours without dying. The only catch is the battery needs to be charged after it dies. Belt seems tight and I am out of ideas

henryclay is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-03-08, 08:02 PM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: Expedition battery will not hold a chrage

New parts doesn't mean they are good. Have it tested to be sure. It also could be as simple as a bad wire or bad connection
thefonz is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome