Expedition engine noise - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-19-04, 05:21 PM Thread Starter
Registered User
 
Join Date: Feb 2004
Posts: 1
Expedition engine noise

I have 68,000 on my Expedition with 5.4L. A week ago, the engine started making a clatter noise when it is started after sitting over night. The noise goes away once it is warmed up. One Ford dealer service writer told me it is not abnormal for this year model.

I would appreciate any comments about this issue.

Thanks.

d

dannyg is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-19-04, 09:40 PM
Registered User
 
Join Date: Sep 2003
Posts: 32
Re: Expedition engine noise

bloody ford dealer service people think everything is normal if its not in their recall list from ford

Last edited by russellw; 02-20-04 at 05:39 AM.
biggiemomo is offline  
post #3 of 3 (permalink) Old 03-14-04, 07:57 PM
Registered User
 
Join Date: Mar 2004
Posts: 155
Re: Expedition engine noise

This is something normal, since you left it sitting overnight that sound is something normal. The oil is all the way at the bottom when you first start it in the morning so it has to be punped up to the top of the engine where the pistons, it takes it a bit to get all the way at the top that is why when it is warm the noise goes away, dont let dealers fool you. this is something normal.
albrjmnz is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome