Expedition Wont Start - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-27-08, 02:36 PM Thread Starter
Registered User
 
Join Date: Jan 2008
Posts: 1
eek Expedition Wont Start

I Have A 98 Eddie Bauer Expedition. I Just Had The Alternator And Belt Replaced. Two Days After I Got It From The Shop It Would Not Start. It Wont Even Turn Over. All The Lights And Radio Works No Power Problems Just Wont Turn Over. If You Get Under The Truck And Jump The Starter With A Screwdriver It Will Start Right Up But If You Put The Key In And Try And Turn It Nothing Happens?

staceyj is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-27-08, 04:14 PM
Registered User
 
Join Date: Dec 2007
Posts: 14
Re: Expedition Wont Start

I would check the starter relay and fuse.

tk
tk1971 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome