Expedition won't start - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-22-2004, 03:30   #1 (permalink)
Registered User
 
Join Date: Apr 2004
Location: Fairbanks, AK
Age: 36
Posts: 2
Expedition won't start

I've just bought 1997 Expedition. And it does not start now. When my key is in ON position, "check engine" and "ABS" lights constantly. Then I'm trying to start, and the engine does not work. The sound is something like trrr very fast. Radio and all electronics work fine. I'll ask for jump start tomorrow, but the sound and "check engine", "abs" lights seem strange to me. What else can I try if the jump start will not help?
Igor is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-24-2004, 12:14   #2 (permalink)
Registered User
 
Join Date: Mar 2004
Posts: 155
Re: Expedition won't start

make sure your terminals(the + and -on your battery) are clean, sometimes they are dirty or have some rust and some times they dont make good contact because of the rust. to check if your battery is good, take one of the cables and join the + and -, if your get a huge spark, your battery is good. The way you describe this issue sound like its some electrical problem. If you have a good battery and everything, the starter might be malfunctioning( I dont know how to chek that, sorry). If you finally find a way to star it and then you try to start it up again, the alternator might be missing. Hope this information helps, good luck.
albrjmnz is offline   Reply With Quote
Old 04-25-2004, 20:09   #3 (permalink)
Registered User
 
Join Date: Apr 2004
Location: Fairbanks, AK
Age: 36
Posts: 2
Re: Expedition won't start

Thanks for the reply. It was the battery. I tried the jump-start from smaller car, and it did not help. But then my friend brought his truck, and my engine started running. I replaced the battery today, and everthing is fine now.
Igor is offline   Reply With Quote
Old 04-28-2004, 15:18   #4 (permalink)
Registered User
 
Join Date: Mar 2004
Posts: 155
Re: Expedition won't start

I'm so glad you fixed your expo, I know it sucks when your car brakes down, especially when you just bought it. Anyways, hope my words were helpfull.
albrjmnz is offline   Reply With Quote
Old 08-11-2004, 17:07   #5 (permalink)
Registered User
 
Join Date: Mar 2004
Posts: 155
Re: Expedition won't start

did u ever fix the thing?
albrjmnz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Ford Expedition Overview RPO83 Ford Expedition Forum | Lincoln Navigator Forum 0 06-22-2003 18:15
2003 Ford Expedition Stacy94PGT Ford Expedition Forum | Lincoln Navigator Forum 1 05-08-2003 09:45
AU hard to start after left for long periods KenOath General Tech 5 04-09-2003 21:19
2003 Ford Expedition Stacy94PGT Ford Worldwide News 1 08-06-2002 11:32
Expedition Is The World’s Cleanest Full-size Suv RPO83 Ford Expedition Forum | Lincoln Navigator Forum 0 06-21-2002 01:26

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 17:21.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.