Groaning & humming 2003 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-26-03, 12:10 PM
expyhawk
Guest
 
Posts: n/a
Groaning & humming 2003

I have read about the front end groaning & humming. My 2003 Expedition had these noises and a grinding when I lock into AWD & 4WD. I took it to my dealer and they replaced the hubs. To no avail, I still have the humming and grinding. Has anyone else had these problems? What is it? What can I do?

 
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 Land Rover Discovery RPO83 Ford Worldwide News 0 10-23-02 11:05 PM
Ford Returns To Its Roots For The Company's 2003 Agm RPO83 Ford Worldwide News 0 10-11-02 07:56 AM
2003 Ford Excursion Overview RPO83 Ford Worldwide News 0 07-26-02 07:07 AM
2003 Ford Taurus Overview RPO83 Ford Worldwide News 0 07-22-02 07:58 AM
Ford Product-Led Transformation: 2003 RPO83 Trans | Driveline 0 07-22-02 07:48 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome