Heated/Cooled Seats - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-06-08, 07:49 PM Thread Starter
Registered User
 
Join Date: May 2008
Posts: 1
Heated/Cooled Seats

Hello All,

I have a 2003 Navigator with the heated/cooled seats. The other day they just stopped working. Both blower motors still run, and both the heat and cool indicator lights turn on, but no heat or air. What is going on? Any help would be great.

Thanks

Bill

Billholthues is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-16-08, 09:34 AM
Registered User
 
Join Date: May 2008
Posts: 2
Re: Heated/Cooled Seats

Hello everybody,
i'm Vale and i'm Italian.
I'm having the same problem on my 03 Navigator, but the heat and cool indicators light don't turns on (on both sides)
We've try to find the problem but we need help from someone that know that car better than us!
Please, help me or let me know where could i find instructions to fix the problems...
Thanks,
Vale
-Vale- is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome