Help! 01 Expedition Oil Pressure Low - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-23-2010, 18:29   #1 (permalink)
Registered User
 
joshwatts's Avatar
 
Join Date: Jun 2008
Posts: 10
Help! 01 Expedition Oil Pressure Low

I need some help! i have an 01 Expedition and when the truck is cold, my oil pressure is 0 and the light comes on but once the truck warms up or you have your foot on the gas pedal it goes back to normal. i think it would be the oil pressure switch and not the pump itself (due to the fact that it is normal once the truck is warmed up) but would like some other opinions.

Thanks

Josh watts
joshwatts@clearwire.net
joshwatts is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-23-2010, 18:44   #2 (permalink)
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 5,855
Re: Help! 01 Expedition Oil Pressure Low

Sounds like a bad pressure switch to me.
jwko is offline   Reply With Quote
Old 02-26-2010, 08:31   #3 (permalink)
Registered User
 
Join Date: Feb 2010
Posts: 3
Re: Help! 01 Expedition Oil Pressure Low

Have / Had the same problem with my 2000 Expedition. Oil gauge bottomed out when you first start the engine from cold. After it warms up a bit light goes out and gauge jumps to normal.
Strangely enough I just changed my oil and had the guys at the shop run that engine cleaner through it. Now the problem is pretty much gone. Not to say that will solve your problem or is the proper way to but thought I would throw that out there.
The part is actually pretty cheap at only 7 bucks, but I actually have no idea where to find it to replace it. Anyone else?
bullettooth is offline   Reply With Quote
Old 02-26-2010, 09:45   #4 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,658
Re: Help! 01 Expedition Oil Pressure Low

The pressure switch is in the lower left front of the engine. It has a white/red wire to it. I believe that's the problem too.
__________________
Bert
Bert is offline   Reply With Quote
Old 02-26-2010, 12:00   #5 (permalink)
Registered User
 
Join Date: Feb 2010
Posts: 3
Re: Help! 01 Expedition Oil Pressure Low

Quote:
Originally Posted by rtg143 View Post
The pressure switch is in the lower left front of the engine. It has a white/red wire to it. I believe that's the problem too.
Thanks for that, I'll replace it soon.
bullettooth is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 01:14.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.