HELP HELPP!!! 03 lincoln navigator low beam headlight doesn't work - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-16-09, 12:06 PM Thread Starter
Registered User
 
Join Date: Jul 2009
Posts: 1
HELP HELPP!!! 03 lincoln navigator low beam headlight doesn't work

The drivers side low beam does not work I opened the headlight and checked everything and it seems to be the main wire that hooks up to the headlight delivers power only for the high beam there is no power for low beam bulb and that's when I plug a bulb directly to the main wire. The passenger side works fine. Any suggestions??

robertrazzouq is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-16-09, 01:18 PM
10 yr FLM Tech
 
fixitnowlt's Avatar
 
Join Date: Jul 2009
Location: Virginia Beach, VA
Posts: 130
Re: HELP HELPP!!! 03 lincoln navigator low beam headlight doesn't work

Have you checked ALL the fuses? Sometimes they had fuses for each lamp.

LT Knowledge IS power 68 Mustang 200, 68 Mustang 302, 89 Tbird SuperCoupe, 94 Tbird 3.8, 94 Bronco XLT 351
www.vehiclesdefined.com
fixitnowlt is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome