help. my expedition 1999 submerged - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-12-2009, 04:30   #1 (permalink)
Registered User
 
Join Date: Nov 2009
Posts: 2
help. my expedition 1999 submerged

hello guys. im from the philippines and the month september hit our country with a powerful storm. my expedition submerge. im dyi it now.

1st remove the electrical on the dashboard. cleaned it with wd40 and cleaning components. everything is cleaned

2nd remove the spark plugs, drained the oil, fuel

3rd remove the water from the piston by enganging it so the water splash.
but still it has some water. suck it with my compressor.

4th compressed the piston with air. and put back the fuse panel under the dashboard so i could start it on the ignition key. the 1st 8 times i cranked it works fine but when i tried to crank it again it wont crank anymore. do you think i should remove the starter and check it for cleaning and repair?

btw i didnt put the plugs for now because it stil have some small water :D

thank you very much guys
xvelocity is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-12-2009, 07:55   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,757
Re: help. my expedition 1999 submerged

Have you tried jumpstarting it? Maybe the battery is too weak. You'll have to drain the differential, trans, and if it has 4wd, the transfer case and front diff.
Bert is offline   Reply With Quote
Old 11-12-2009, 08:09   #3 (permalink)
Registered User
 
Join Date: Nov 2009
Posts: 2
Re: help. my expedition 1999 submerged

thanks for the reply sir, not yet but the battery im using does start on cars. and when i tried directing the starter to the positive terminal the engine cranks, it is 4wd i checked the crankcase of the tranny no water was inside and im goin to check on the differential in the morning. do you think i should remove the starter and check for corroded parts? thanks again
xvelocity is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 21:09.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.