Instrument cluster for 03 Navigator - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-05-2012, 15:01   #1 (permalink)
Registered User
 
Join Date: Apr 2012
Posts: 1
confused Instrument cluster for 03 Navigator

The lights in my instrument cluster dont seem to light up. The needles light up, but the actual digits for the speedo/tach do not. Dealer told me the whole cluster needs replacing, but they told me the part is obsolete/discontinued. I tried a bunch of auto wreckers hoping to find a used one, but I had no luck. Has anybody had the same problem? Is there a way I may be able to get the unit repaired? or does anybody know where I might be able to get a new one? I would need one made for a canadian truck with KMH on top and MPH underneath. Any help would be greatly appreciated!
iceman1304 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-05-2012, 15:10   #2 (permalink)
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 5,941
Re: Instrument cluster for 03 Navigator

Contact this ebay seller eBay - New & used electronics, cars, apparel, collectibles, sporting goods & more at low prices They fixed the digital odometer on my truck. You'll have to remove it and send it in, they repair it and send it back.
jwko is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 19:55.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.