Lost my parking, tail, instrument, registration light... Anyone with a tip? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 12-13-12, 02:56 PM Thread Starter
Registered User
 
Join Date: Sep 2009
Posts: 18
Lost my parking, tail, instrument, registration light... Anyone with a tip?

I have a 2003 Expedition and today I lost my parking, tail, instrument, registration light.
If i switch over to Auto everything is normal.
I have checked fuses

Where shall I look next ?

Svein is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 12-14-12, 12:27 PM Thread Starter
Registered User
 
Join Date: Sep 2009
Posts: 18
Re: Lost my parking, tail, instrument, registration light... Anyone with a tip?

And also foglight...
Svein is offline  
post #3 of 9 (permalink) Old 12-14-12, 01:00 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,694
Re: Lost my parking, tail, instrument, registration light... Anyone with a tip?

Dont know if this helps you , re. checking SJB (smart junction box )

2007 ford expedition: tail lights..fuses..the only lamps not working - JustAnswer
R.S.LOGAN is offline  
post #4 of 9 (permalink) Old 12-14-12, 01:21 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,694
Re: Lost my parking, tail, instrument, registration light... Anyone with a tip?

Or faulty switch ?
R.S.LOGAN is offline  
post #5 of 9 (permalink) Old 12-18-12, 05:46 AM Thread Starter
Registered User
 
Join Date: Sep 2009
Posts: 18
Re: Lost my parking, tail, instrument, registration light... Anyone with a tip?

Hi,

Where is the SJB located?
Svein is offline  
post #6 of 9 (permalink) Old 12-18-12, 05:53 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,694
Re: Lost my parking, tail, instrument, registration light... Anyone with a tip?

Where is the Smart Junction Box on 2003 ford expedition
R.S.LOGAN is offline  
post #7 of 9 (permalink) Old 12-18-12, 02:37 PM Thread Starter
Registered User
 
Join Date: Sep 2009
Posts: 18
Re: Lost my parking, tail, instrument, registration light... Anyone with a tip?

Thanks a lot Logan :-)

I will check the wires tomorow
Svein is offline  
post #8 of 9 (permalink) Old 06-10-13, 02:33 PM Thread Starter
Registered User
 
Join Date: Sep 2009
Posts: 18
Re: Lost my parking, tail, instrument, registration light... Anyone with a tip?

Problem solved...

Broken fuse on a switch for automatic driving lights.
Svein is offline  
post #9 of 9 (permalink) Old 06-10-13, 02:46 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,694
Re: Lost my parking, tail, instrument, registration light... Anyone with a tip?

Good to hear problem solved and it was something minor .Thanks for updating the forum .
R.S.LOGAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome