Mach Audio System Sub Problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-06-2005, 15:28   #1 (permalink)
Registered User
 
Join Date: Jun 2005
Location: Massacusetts
Posts: 1
Mach Audio System Sub Problems

The sub in my 2001 Expedition stopped working but the door speakers are working fine. There is no information about the sub anywhere in the manual. Are there any reset buttons or fuses that can cusing the problems?? Any help would be appreciated. Thanks!
Romiz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-06-2005, 17:31   #2 (permalink)
god
Registered User
 
Join Date: May 2005
Location: Baltimore
Age: 28
Posts: 11
Re: Mach Audio System Sub Problems

there has to be a fuse somewhere, i dont know anything about that because my sounds system is 100% aftermarket
god is offline   Reply With Quote
Old 10-07-2008, 03:44   #3 (permalink)
Registered User
 
Join Date: Oct 2008
Posts: 3
Re: Mach Audio System Sub Problems

I drive a 03 Escape Limited and it has the same problem,fuses are fine,ven I put brand new fuse in it.Would any one help?Much appreciate!!
superid111 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 23:08.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.