Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 10-29-13, 05:03 PM Thread Starter
Registered User
Join Date: Oct 2013
Posts: 1
navi heater booster

yet another winter and navi heat works down the hwy sometimes. not in the rear around town . Both heater cores flow great front is brand new blend door in perfect condition , engine temps are where they should be and coolant is really full. so none of these are my problem. pretty much my idea is that im not getting the necessary amount of flow. so an intercooler coolant pump came into mind. the same therory is used on school busses they use a booster pump. so i thought a navi is close could plumb pump into output line to boost the flow to keep things toasty. just looking for thoughts or any concerns with this modifacation.
87chyconquest is offline  
post #2 of (permalink) Old 10-29-13, 05:14 PM
Dazed and Confused
CatSkinner's Avatar
Join Date: May 2012
Location: Upstate New York
Posts: 5,282
Re: navi heater booster

Sounds to me like your water pump is wearing. A booster will help solve the rear heat problem, but you may be looking at a bigger problem down the road. Also, you'll want to keep the pump relatively small so that you don't over drive the system and/or rob coolant from someplace else.

Chewing on asphalt and drinking dinosaur wine
CatSkinner is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome