Navigator Navigation issue - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-06-2009, 04:34   #1 (permalink)
Registered User
 
Join Date: Apr 2009
Posts: 6
Navigator Navigation issue

Hello all,

I just purchased an 03 Navigator with the Navigation and 6 disc system. It worked fine for the first couple days but now I am getting a CD error. I have all 6 CD's slots loaded and it will not let me eject any of them. It will start to play on of the CD's but when I go to change over to another CD, is when I get the CD error. Also when this happens I am unable to make my screen go back into position. What do I need to do to get the CD's out and also what is the problem.

Thanks for your help!

Mike
AllezRocket is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-27-2009, 08:52   #2 (permalink)
Registered User
 
Join Date: Apr 2009
Posts: 6
Re: Navigator Navigation issue

No one posted a reply but I do have an update with this. Crazy as it sounds it seems to be weather/temperature related. When the temp is over 50degrees the unit works fine. When it gets around 40 degrees it starts acting up again. This repeated itself consistently over the past 2 weeks I have no idea on this but for now it is working.
AllezRocket is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 17:29.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.