navigator wont start please help! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-20-09, 05:04 PM Thread Starter
Registered User
 
Join Date: Nov 2009
Posts: 10
navigator wont start please help!

Ok so i was testing my alarm/door locks ecu with my circuit tester and something happened and now none of my accessories work on my truck. I tried starting it and it clicks in the ecu and under the hood but wont start and no lights come on or anything. Checked all my fuses and none of the accessory ones show they work with my circuit tester but when i pull all the fuses out they are all good. Does anybody know anything that can help me out on this? Thank you.

navigator19 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome