Need MAF housing and sensor!!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-08-01, 01:08 PM Thread Starter
Crown Vic Member
 
Join Date: Feb 2001
Posts: 9
Need MAF housing and sensor!!!

I need the MAF housing and sensor from a late model (99-01) Expedition with the 5.4L V8. The part # is:

XL3Z-12B579-BA

Anyone have any spare takeoffs lying around? :D

metroplex is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Just got fairmont cluster what do i need??? AU1SIXA General Tech 7 09-12-02 06:43 AM
Cooling Fan sensor problems '91 Tempo Mike Pfleger Ford Tempo Forum | Mercury Topaz Forum 0 08-11-02 07:08 AM
Understanding Engine Management - Part 1 Dan [Sac] V6 and Hot4 Tech 0 12-11-01 02:08 PM
What could be the cause of my temp gauge not working? Chrisbronco Ford Bronco Forum 2 06-27-01 04:36 PM
Need MAF housing and sensor!!! metroplex Ford F-100 | Ford F-150 | Ford F-250 | Ford F-350 | Ford Super Duty | Ford Diesel 0 06-08-01 01:09 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome