No running and parking lights on EXPY 2003 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-01-2010, 08:58   #1 (permalink)
Registered User
 
Join Date: Sep 2009
Posts: 18
Question No running and parking lights on EXPY 2003

Hi,

I lost my lowbeam headlights and also parking lights.
Hibeam and flash to pass are working.
Have checked all fuses and they looks good.

Any suggestions?
Svein is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-01-2010, 09:41   #2 (permalink)
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,708
Re: No running and parking lights on EXPY 2003

multi function switch
thefonz is offline   Reply With Quote
Old 07-01-2010, 10:17   #3 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,845
Re: No running and parking lights on EXPY 2003

The parklights don't run through the multi-function switch. It's possible the headlight switch or connectios are bad.
__________________
Bert
Bert is offline   Reply With Quote
Old 07-08-2010, 02:40   #4 (permalink)
Registered User
 
Join Date: Sep 2009
Posts: 18
Re: No running and parking lights on EXPY 2003

Fixed it....Both lightbulbs was broken.....
Svein is offline   Reply With Quote
Old 07-08-2010, 08:16   #5 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,845
Re: No running and parking lights on EXPY 2003

How about the parking lights? Glad you got it fixed.
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 05:33.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.