Oil use 1 quart every 1,500 miles too much? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-28-08, 04:51 AM Thread Starter
Registered User
 
Join Date: Dec 2008
Posts: 1
Oil use 1 quart every 1,500 miles too much?

I have an '05 Navigator 2wd. It has 68,000 on it and I bought it this summer with 54,000 miles on it.

It uses a quart of oil about every 1,500 miles. I put full synthetic oil in it and have changed it 3 times since I got it.

Does this type of oil use seem normal for the 5.4 engine?

This is my first ford product. My dad has an '00 4wd f-150 with the same engine and it uses no oil.

What can be done and should i consider getting rid of it before it developes major problems?

Thanks for the advice!!
dkwebb2727 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome