One last problem..... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 09-23-10, 02:13 PM Thread Starter
Registered User
 
Join Date: Sep 2010
Location: utah
Posts: 12
One last problem.....

i have searched all 46 pages of threads and found answers to all of my questions but one.... The lights on my 98 navi are all pulsating (all lights and at the same time)!!! I was just checking to see if anyone on here had something similar happen.... I wonder if it is a voltage regulator issue or something unique to these vehicles... I thank you for your responses
eswear is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-23-10, 02:35 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,283
Re: One last problem.....

When it's pulsating, check the voltage at the battery and at the alternator. It could be the alternator causing that. Possible connectios in the charging circuit.

Bert
Bert is offline  
post #3 of 5 (permalink) Old 09-23-10, 05:08 PM
Registered User
 
KStromberg's Avatar
 
Join Date: Feb 2010
Location: Minnesota
Posts: 281
Garage
Re: One last problem.....

Quote:
Originally Posted by Bert View Post
Possible connectios in the charging circuit.
Bert, it's funny you say that because the older 90-94 Town Cars had a gray connector under the hood named after you that caused this same issue.

But yeah, follow Bert's advice. He's not the "bad" version.

-1992 Ford F-150 (winter truck)
-1998 Lincoln Mark VIII LSC (fun car)13.591@101.72mph
KStromberg is offline  
post #4 of 5 (permalink) Old 09-23-10, 05:20 PM Thread Starter
Registered User
 
Join Date: Sep 2010
Location: utah
Posts: 12
Re: One last problem.....

Thanks bert... its a new battery and a 2 year old alternator... I don't have a volt meter right now is there another way to check the charging circuits?
eswear is offline  
post #5 of 5 (permalink) Old 09-23-10, 05:25 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,283
Re: One last problem.....

That's the only way to be sure what's going on. You can get a cheap multimeter for hardly anything.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome