one power vent window not working 2003 expedition - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-27-09, 08:21 PM Thread Starter
Registered User
 
Join Date: Aug 2009
Location: Kansas
Posts: 2
one power vent window not working 2003 expedition

2003 Expedition EB - The driver's side vent window does not open, but the passenger side does. I cannot hear the motor working and have yet to check to see if it is getting power. Anybody else seen this problem? Do the motors go bad? The manual insinuates that both vent motors are on the same circuit/fuse.

thanks,
Brandon

BSpencerKansas is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-27-09, 08:34 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,342
Re: one power vent window not working 2003 expedition

They are on the same circuit but they run off of different switches. Not sure about weaknesses.
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome