Overdrive light keeps flashing - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-13-12, 08:07 PM Thread Starter
Registered User
 
Join Date: Apr 2012
Posts: 1
Overdrive light keeps flashing

I have a 2000 ford expedition 5.4 The overdrive light keeps flashing and I cant turn it off. The truck wont drive when I put it in drive. It just idles real high but I wont go. I have to drive it in drive 2 or 1. I used the car md and it said it was code 0443 the EVAP Canister purge solenoid. Does this sound like the reason the overdrive light is flashing and it doesn't want to go in drive?

stacey2678 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-14-12, 07:54 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,315
Re: Overdrive light keeps flashing

There has to be a trans code and it takes a better reader to pull them. You could try Autozone.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome