Park Assist & Reverse Lights not working - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-06-2010, 01:53   #1 (permalink)
Registered User
 
Join Date: Oct 2010
Posts: 7
Park Assist & Reverse Lights not working

Hey guys I own a 2005 Lincoln Navigator, the Park Assist light keeps coming up on the message display and there is no nose at all coming from my park assist when put in reverse and also my reverse lights do not work, I checked the no 10 fuse and it seems to be fine, any other ideas of what it could be? thanks
yamahar6 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-06-2010, 09:05   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,844
Re: Park Assist & Reverse Lights not working

Have someone watch for the reverse ights as you move the shift lever through the gears. Maybe the transmission range selector is giong out.
__________________
Bert
Bert is offline   Reply With Quote
Old 10-06-2010, 15:19   #3 (permalink)
Registered User
 
Join Date: Oct 2010
Posts: 7
Re: Park Assist & Reverse Lights not working

Quote:
Originally Posted by Bert View Post
Have someone watch for the reverse ights as you move the shift lever through the gears. Maybe the transmission range selector is giong out.

Thanks Bert, where is the transmission range selector located?
yamahar6 is offline   Reply With Quote
Old 10-06-2010, 15:26   #4 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,844
Re: Park Assist & Reverse Lights not working

It's on the transmission at the lever. Did they come on moving the lever?
__________________
Bert
Bert is offline   Reply With Quote
Old 10-06-2010, 15:37   #5 (permalink)
Registered User
 
Join Date: Oct 2010
Posts: 7
Re: Park Assist & Reverse Lights not working

Quote:
Originally Posted by Bert View Post
It's on the transmission at the lever. Did they come on moving the lever?
No unfortunately they did not, my "check park assist" light stays on at all times
yamahar6 is offline   Reply With Quote
Old 10-06-2010, 16:45   #6 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,844
Re: Park Assist & Reverse Lights not working

Then it could be anywhere in the system. You need a manual to track it down.
Was there power at the fuse? Are fuses #14 and #27 okay and have power to the in the run position?
__________________
Bert
Bert is offline   Reply With Quote
Old 10-07-2010, 01:19   #7 (permalink)
Registered User
 
Join Date: Oct 2010
Posts: 7
Re: Park Assist & Reverse Lights not working

Fuses look fine, I think I'm just going to take the it to the dealership and have them diagnose it for me then repair myself if possible, thanks for the help bert
yamahar6 is offline   Reply With Quote
Old 10-07-2010, 09:13   #8 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,844
Re: Park Assist & Reverse Lights not working

Sorry we couldn't get it. Post back what you find out.
__________________
Bert
Bert is offline   Reply With Quote
Old 10-15-2010, 21:03   #9 (permalink)
Registered User
 
Join Date: Oct 2010
Posts: 7
Re: Park Assist & Reverse Lights not working

So I took the truck into the dealership and the tech there had advised me that wires from the MLP sensor to relay were corroded or shorted and that this is a common problem. That problem then stops the parking aid and backup lights from working (they share the same circuit). So now they are going to track down the corroded/shorted wire and replace it. Wow this is a headache, and hurts my pocket at $135.00 an hour. I hope it helps someone who is dealing with the same problem.

Cheers
yamahar6 is offline   Reply With Quote
Old 10-15-2010, 21:09   #10 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,844
Re: Park Assist & Reverse Lights not working

Thanks for the update. Soetimes that's the only way to get something fixed and not have the headaches with searching for weeks.
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 09:29.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.