Please my expedition is dead HELP!!!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-17-2010, 20:19   #1 (permalink)
Registered User
 
Join Date: Oct 2010
Posts: 5
Please my expedition is dead HELP!!!!

Hey so i have a 98 expedition and last night i was driving it home from the store , oh heck i should start from the start. So i got in my expedition started it and put it in reverse backed up and then put it in drive when i went to go forward the car jerked and i thought oh no big deal must not of put it in drive all the way , then i got on the road made a turn and the car died. All lights work and radio works. No power stering no power brakes nothing...So the car will crank but no start...We have sprayed starting fluid in the air intake and nothing..Mt theft light flashes like crazy when i try to start it..I dont get it..Can someone help me..I know my starter , battery and alternator are all good...I really need my car back up and running..Thank you...
proudmommy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-17-2010, 21:12   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,705
Re: Please my expedition is dead HELP!!!!

Sounds like something is up with the PATS system. Have you tried a different key?
__________________
Bert
Bert is offline   Reply With Quote
Old 10-17-2010, 22:07   #3 (permalink)
Registered User
 
Join Date: Oct 2010
Posts: 5
Re: Please my expedition is dead HELP!!!!

I have not tried a different key. I have to get a new one made tomorrow. But if my key wasn't working right would that make my car die while driving it? And would my car crank but not start? Do you have a phone number i may call you at? I'm just so stressed out...
proudmommy is offline   Reply With Quote
Old 10-18-2010, 18:30   #4 (permalink)
Registered User
 
Join Date: Oct 2010
Posts: 5
Arrow Re: Please my expedition is dead HELP!!!!

Ok so my car starts now , had a lock smith come out and clear my code and all is good...Just need to figure out what causes it..So here is the code any ideas? Faulty link between PATS module and EECV
proudmommy is offline   Reply With Quote
Old 10-18-2010, 20:30   #5 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,705
Re: Please my expedition is dead HELP!!!!

That could be a connection problem in the circuit. Did the locksmith have any suggestions?
__________________
Bert
Bert is offline   Reply With Quote
Old 10-19-2010, 15:35   #6 (permalink)
Registered User
 
Join Date: Oct 2010
Posts: 5
Arrow Re: Please my expedition is dead HELP!!!!

Nope he had no clue...But i had a guy tell me he had the same thing happen to him and ford replaced his battery connections and it fixed it , so that's what im doing today...
proudmommy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 23:44.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.