Questions on Misfire on '07 Navigator w/5.4 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-23-2014, 17:30   #1 (permalink)
Registered User
 
Join Date: Mar 2014
Posts: 6
Questions on Misfire on '07 Navigator w/5.4

I am new to the Forum and Ford vehicles, so I hope I am doing this query correctly.
I bought this Navigator with 163K on it, been regularly serviced by Lincoln. The Service Records show a misfire on #2 at 103K, with a full tune up done at 111K. About a week ago, at 164K, I started getting the check engine light and could feel a misfire. A Scan Run shows it to be #7 misfiring.
Would you pull all the plugs and check condition, or just replace the #7 and the coil? Also, is there any type mileage between tune-ups, or anything like that. Prior to this I have been running a '98 Silverado with about 200K; so I never seen coils to each plug. Any info you can provide will be appreciated. Ron
Traveller_2007 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-23-2014, 18:31   #2 (permalink)
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 3,571
Re: Questions on Misfire on '07 Navigator w/5.4

Others may disagree, but I'm a little bit old school, I'd pull all the plugs and do some comparisons. If they all look beat, replace them all, if just number 7 looks hammered, you may have another issue going on. Newer plugs run a lot longer than the old, the ones I just put in my truck are suposed to be good for 100K and it has a '92 engine in it.
__________________
'Scuse me, while I scrape this Honda outta my treads.
CatSkinner is offline   Reply With Quote
Old 03-24-2014, 04:51   #3 (permalink)
Moderators
 
r-clar's Avatar
 
Join Date: Feb 2013
Location: Demotte Indiana
Posts: 934
Re: Questions on Misfire on '07 Navigator w/5.4

It's a 5.4 3valve motor and the plugs like to break off in the head. I will advise caution doing them at home without the tools to remove. First is a 9/16 spark plug socket,second is an extractor set for the broken plugs. Lisle makes the best one in my opinion. Not terrible to use or do but can be very frustrating especially #7 since it's a rear plug and difficult to get to. And on those plugs I would replace or have them all replaced with those miles. They don't last as long as they should and the truck will run much better with fresh plugs. Also make sure the coil is good. Don't change as many coils on those but is possible.


Sent from AutoGuide.com App
r-clar is offline   Reply With Quote
Old 03-25-2014, 18:41   #4 (permalink)
Registered User
 
Join Date: Mar 2014
Posts: 6
Re: Questions on Misfire on '07 Navigator w/5.4

I took it to the Ford Dealer, said replace all plugs and the coil for #7. I had read about the possibly of plugs breaking, and at 72.....not ready for that! Should get it back tomorrow, and will surely see a major improvement. Thanks for the inputs, glad to be a member of this group. Ron.
Traveller_2007 is offline   Reply With Quote
Old 03-29-2014, 20:04   #5 (permalink)
Registered User
 
Join Date: Mar 2014
Posts: 6
Re: Questions on Misfire on '07 Navigator w/5.4

Picked it up this afternoon; LOF, new coil for #7 and 8 new plugs - $735.00. I damned near died when he said it, but I couldn't do it, they stand behind there work, and it does run great. Does anyone know if Ford is going to come out with a better plug? Ron
Traveller_2007 is offline   Reply With Quote
Old 03-30-2014, 06:03   #6 (permalink)
Moderators
 
r-clar's Avatar
 
Join Date: Feb 2013
Location: Demotte Indiana
Posts: 934
Re: Questions on Misfire on '07 Navigator w/5.4

The new ones seem to come out a little better but unfortunately I don't really see a way to Make them any better. They have been updated many times but unsure of what they changed. Heard of an aftermarket kit to put standard plug in but I don't see how that would work properly. Not going to put the plug in the correct spot for proper ignition.


Sent from AutoGuide.com App
r-clar is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 11:29.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.