Starter or Ignition switch ? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-29-12, 08:54 AM Thread Starter
Registered User
 
Join Date: Feb 2011
Posts: 60
Starter or Ignition switch ?

Okay, what appears to be the problem? My remote start button got pressed down one time and the truck kept trying to start, but wouldn't.

I went out to start it one day, and it just clicks when you turn the key over. It doesn't attempt to crank at all. If I turn the key to run, and jump the two posts on the solenoid on the firewall with a screwdriver, it starts right up with no hesitation. Any idea what the problem is?

(For a long time, i've had the door chime ding even with the key out of the ignition and door open, not sure if that's related or not)
ex0r is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-29-12, 02:36 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 13,938
Re: Starter or Ignition switch ?

Faulty solenoid ?
R.S.LOGAN is offline  
post #3 of 4 (permalink) Old 03-30-12, 05:24 AM Thread Starter
Registered User
 
Join Date: Feb 2011
Posts: 60
Re: Starter or Ignition switch ?

on the firewall, or the starter?

I wouldn't suspect the starter being bad since if I jump it it starts up, nor would I think the solenoid on the firewall is bad as I can jump that, too. I was thinking the ignition switch wasn't sending the signal to the solenoid, although you can hear a very distinguished 'click' when you turn the key over.
ex0r is offline  
post #4 of 4 (permalink) Old 03-31-12, 10:51 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 13,938
Re: Starter or Ignition switch ?

Whatever one you bridge .
R.S.LOGAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome