TPMS Reset in 2005 Expedition - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-25-06, 01:45 PM Thread Starter
Registered User
 
Join Date: Oct 2006
Posts: 1
confused TPMS Reset in 2005 Expedition

Just had a flat fixed and do not know how to reset the TPMS, does anyone know how in a 2005 Expedition?

Thx

nepats02 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-25-06, 06:34 PM
Hi-Tech Redneck
 
Johnny Mullet's Avatar
 
Join Date: Jun 2006
Location: Ashtabula, Ohio
Age: 46
Posts: 1,486
Re: TPMS Reset in 2005 Expedition

Set all tire pressures.
Turn the key to the "ON" position.
Take a good magnet to each wheel and hold at valve stem for 5 seconds each wheel one at a time.
Done!
Johnny Mullet is offline  
post #3 of 4 (permalink) Old 10-26-06, 02:14 PM
Hi-Tech Redneck
 
Johnny Mullet's Avatar
 
Join Date: Jun 2006
Location: Ashtabula, Ohio
Age: 46
Posts: 1,486
Re: TPMS Reset in 2005 Expedition

********EDIT************

I just had one in today. Hold the magnet at each wheel one at a time for 9 seconds each.
Johnny Mullet is offline  
post #4 of 4 (permalink) Old 02-02-07, 08:27 PM
Registered User
 
Join Date: Feb 2007
Posts: 1
Re: TPMS Reset in 2005 Expedition

Was the time when you tried the reset when the display read "Tire pressure system fault"?
Did it work?
leyva is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome