TSB 03-6-4 (or #17632) - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-24-06, 12:20 PM Thread Starter
Registered User
 
Join Date: Oct 2006
Posts: 4
TSB 03-6-4 (or #17632)

I took my '03 Expedition into the dealer because there was a while/howl at 40-50mph coming from the front end. I thought maybe it was a wheel bearing going on me. The dealer inspected and said I needed to have TSB 3-6-4 performed to correct the problem. I know you can get these TSB's online, but it seems you have to pay for them at all the sites I found.

Can anyone get me a copy of this TSB? Thanks.
jrudolph is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-24-06, 02:01 PM
Hi-Tech Redneck
 
Johnny Mullet's Avatar
 
Join Date: Jun 2006
Location: Ashtabula, Ohio
Age: 45
Posts: 1,486
Re: TSB 03-6-4 (or #17632)

ISSUE:
Some 2003 Expedition/Navigator 4X4 vehicles may exhibit a front axle groan or hum, and/or a slight vibration, when operated in the 2 High mode. This condition is most noticeable on deceleration between 45 and 15 mph, and is not present in A4WD or 4 High. This may be due to the front halfshafts rotating at different speeds when the vehicle is operated in 2 High.

ACTION:
To service, install S-spring (clutch spring) into the front axle differential, causing the front halfshafts to rotate at the same speed in 2 High mode. Refer to the following Service Procedure for details.
Johnny Mullet is offline  
post #3 of 3 (permalink) Old 10-24-06, 02:46 PM Thread Starter
Registered User
 
Join Date: Oct 2006
Posts: 4
Re: TSB 03-6-4 (or #17632)

Mullet Man,

Can you send me a copy of the TSB so I can look at it (like by email or fax)?
Thanks.
jrudolph is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome