Turn Signal Troubles - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-13-2010, 07:04   #1 (permalink)
Registered User
 
Join Date: Oct 2010
Posts: 7
Turn Signal Troubles

I have a 2003 Expedition. I am having issues with the turn signals. When activated, the turn signal may blink once, twice, you may hear the signal activate but not blink. The emergency blinkers work fine. The few times it does work, once you brake to make the turn, the signal quits. I am old school and when I initially thought the fix may be to replace the signal relay, I was told that the newer vehicles do not have a relay but it is controled internally by the switch itself. Does anyone have an idea on how to troubleshoot this issue? My wife has already been pulled over for not using the turn signals, thankfully she only received a warning. Any thoughts on this would be greatly appreciated. Thanks.....
CooCooie is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-13-2010, 09:36   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,889
Re: Turn Signal Troubles

It may be the turn signal switch itself.Spray some electrical contact cleaner down around the hazard switch and operate the hazards a few times. If they work better then, you'll eventually have to replace the switch. It's simple to change and the steering wheel doesn't have to be removed.

If that doesn't and the flasher is the problem the flasher probably is. The flasher is located behind the instrument panel on the driver's side. It's right above the emergency brake assembly below the headlight switch. You can hear it with the hazards on to locate it. The flasher has a cover over it. It's a black plastic box that's about 3" long and 1 1/2" wide and is held on with plastic clips on the ends of the box.
__________________
Bert
Bert is offline   Reply With Quote
Old 10-13-2010, 09:39   #3 (permalink)
Registered User
 
Hamfisted's Avatar
 
Join Date: Jul 2010
Location: South Florida
Posts: 56
Re: Turn Signal Troubles

Yes, it sounds like the switch assembly failing. The new assembly is about $75 at RockAuto. The switches for the emergency flashers and turn signals, as well as the wipers and washer pump switch. Lot of stuff crammed into it to fail. But hey, they save 5 minutes during the vehicle assembly process stuffing it all into one plastic heap....


- Mike
Hamfisted is offline   Reply With Quote
Old 10-15-2010, 06:23   #4 (permalink)
Registered User
 
Join Date: Oct 2010
Posts: 7
Re: Turn Signal Troubles

Bert / Hamfisted

Thanks, I'll look at it this weekend.... hopefully it is that easy and not a dead short or something that requires technician troubleshooting.... this forum is AWSOME..!!
CooCooie is offline   Reply With Quote
Old 10-15-2010, 06:24   #5 (permalink)
Registered User
 
Join Date: Oct 2010
Posts: 7
Re: Turn Signal Troubles

BTW.. Hamfisted, I don't know if you saw my reply to your post regarding my issues with the climate control issue but you were dead on... thanks again!!!
CooCooie is offline   Reply With Quote
Old 11-02-2010, 16:00   #6 (permalink)
Registered User
 
Hamfisted's Avatar
 
Join Date: Jul 2010
Location: South Florida
Posts: 56
Re: Turn Signal Troubles

Coocooie I forgot to ask. Do you hear the relay clicking like it's trying to blink? Or do you just hear one contact and then nothing? The flasher is in the Aux Relay Box up there behind the driver's left knee bolster area, it's about the size of one of those big stick match boxes, held up there with a 8mm bolt on either end. It contains the standard 5-pole flasher plugged in. You can feel for it with your hand, or use a mirror and light to see it. It's just up above the Parking Brake Release handle area.


- Mike



Here's a pic ....

Hamfisted is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 01:35.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.